Hauptseite > Voraussetzungen

Was wird benötigt?

Um Bludit zu verwenden, braucht es einen Server mit

  • PHP v5.3 oder höher.

Zudem müssen folgende Module installiert und aktiviert sein:

  • PHP-Modul mbstring zur Unterstützung von UTF-8.
  • PHP-Modul gd zur Grafikbearbeitung.
  • PHP-Modul dom zur DOM-Erweiterung.
  • PHP-Modul json zur Verwendung des Datenaustauschformats JSON.

  • Unterstützte Server:
  • Andere Server.

Bei einem normalen Webhosting sind diese Voraussetzungen üblicherweise erfüllt. Eine höhere Version von PHP kann die Installation schneller machen.

Die Standardinstallation von Bludit selbst benötigt rund 2 MB Speicherplatz. Auch das stellt bei einem normalen Webhosting kein Problem dar.

Aus Sicherheitsgründen sollte derzeit keine der Versionen unter PHP Version 5.6 verwendet werden, da diese nicht mehr unterstützt werden und somit ein Sicherheitsrisiko darstellen.

Welche Version von PHP und welche Module sind installiert?

Control-Panel

Die verwendete PHP-Version sowie die aktiven Server-Module werden meistens im Control Panel des Webhostings angezeigt.

Datei phpinfo.php

Die PHP-Version kann auch mit einer Datei phpinfo.php mit folgendem Inhalt angezeigt werden:

<?php
   phpinfo();
?>

Die Datei kann auf den Server geladen und im Browser unter dem Domainnamen mit phpinfo.php aufgerufen werden.

Die Datei sollte nach Gebrauch umgehend gelöscht werden, da der durch sie mögliche Abruf von Server-Informationen ein Sicherheitsrisiko darstellen kann.

Bludit

Bei einer Bludit-Installation wird die PHP-Version auch unter "Einstellungen" > "Über" angezeigt.

Zusätzliche Informationen

Zusätzlich Informationen sind in der offiziellen Bludit-Dokumentation unter Voraussetzungen zu finden.

Letzte Änderung: 30. Mai 2017.